TOPIC: fa-icons don't display

fa-icons don't display 04 Apr 2016 16:26 #1688

Hi I have in issue when I enable JotCache plugin my cached page don't have any fa-icons.

Joomla version : 3.4
JotCache version : 5.3.1
site template: Ts_dailytimes
system plugins :
The administrator has disabled public write access.

fa-icons don't display 06 Apr 2016 11:30 #1691

Check if icons are not loaded with relative URL. Manytimes the problem can be solved with additional '/' character prepended before original relative URL. The reason for such behavior is different part of Joomla core code which is responsible for page presentation in case of cached and non-cached page.
The administrator has disabled public write access.

fa-icons don't display 26 Sep 2016 23:31 #1809

I am having the same problem. All the fa-icons on my template do not display when I enable the jotcache plugin. is there a way to fix this?

I am using Joomla 3.5.1 and the latest JotCache plugin
The administrator has disabled public write access.

fa-icons don't display 27 Sep 2016 10:07 #1811

Find on your site CSS file containing FontAwesome definition. Something similar to this example :
@font-face {
    font-family: "FontAwesome";
    font-style: normal;
    font-weight: normal;
    src: url("../../../media/foundry/3.1/styles/font-awesome/font/fontawesome-webfont.eot?#iefix&v=3.2.1") format("embedded-opentype"), url("../../../media/foundry/3.1/styles/font-awesome/font/fontawesome-webfont.woff?v=3.2.1") format("woff"), url("../../../media/foundry/3.1/styles/font-awesome/font/fontawesome-webfont.ttf?v=3.2.1") format("truetype"), url("../../../media/foundry/3.1/styles/font-awesome/font/fontawesome-webfont.svg#fontawesomeregular?v=3.2.1") format("svg");
}
Replace all url link with absolute URL of your site.
The administrator has disabled public write access.

fa-icons don't display 27 Sep 2016 19:22 #1812

JotComponents wrote:
Find on your site CSS file containing FontAwesome definition. Something similar to this example :
@font-face {
    font-family: "FontAwesome";
    font-style: normal;
    font-weight: normal;
    src: url("../../../media/foundry/3.1/styles/font-awesome/font/fontawesome-webfont.eot?#iefix&v=3.2.1") format("embedded-opentype"), url("../../../media/foundry/3.1/styles/font-awesome/font/fontawesome-webfont.woff?v=3.2.1") format("woff"), url("../../../media/foundry/3.1/styles/font-awesome/font/fontawesome-webfont.ttf?v=3.2.1") format("truetype"), url("../../../media/foundry/3.1/styles/font-awesome/font/fontawesome-webfont.svg#fontawesomeregular?v=3.2.1") format("svg");
}
Replace all url link with absolute URL of your site.

Thank you for showing me how to do that, that actually fixed the problem!

One last question, do I need to disable Joomla Cache in global configuration, or should it be enabled as well as the JotCache plugin
The administrator has disabled public write access.

fa-icons don't display 28 Sep 2016 07:58 #1813

If your web site is working well with enabled Global Configuration Cache along with disabled JotCache then you can without problems use both caches in enabled state.
The administrator has disabled public write access.
Time to create page: 0.275 seconds
We have 110 guests and no members online
Copyright © 2015 JotComponents
We have 110 guests and no members online
Copyright © 2017 JotComponents