TOPIC: Problem with optimize

Problem with optimize 17 Feb 2015 17:56 #1220

Jotcache doesn't work in combination with JCH optimize on my site.
Initially all works fine but then after some time optimization is lost on one page while still available on all other pages.
Very strange behavior. It seems that JotCache and JCH Optimize don't get along.
Very sad! This is what we all would like to work but no...

Joomla version : 3.3
JotCache version : 5.01
site template:
system plugins : sh404SEF, JCH Optimize
The administrator has disabled public write access.

Re: Problem with optimize 23 Feb 2015 05:38 #1228

On many live sites is working JCH Optimize along with JotCache. Sometimes is necessary to set JCH parameter Minify HTML to No.
First try to install latest JotCache (5.0.8).
The administrator has disabled public write access.

Re: Problem with optimize 23 Feb 2015 16:52 #1229

OK, I will give that a try.
It will take some time though before I have time to check it.
Currently my site is running fine with standard joomla cache, but I prefer to use Jotcache.
Of course I installed the latest Jotcache version.

Regards.
The administrator has disabled public write access.

Re: Problem with optimize 01 Mar 2015 16:08 #1260

I have the identical problem with Joomla 3.4 and JotCache 5.0.8b4 with JCH.

Initially, on my home page, CSS and JS files are combined in to a PHP file. After a few page reloads, the optimization is gone. It seems to be an issue when JotCache enabled.

Jordan


Joomla version : 3.4
JotCache version : 5.0.8b4
site template: RocketTheme Ximenia
system plugins : JCH optimize
The administrator has disabled public write access.

Re: Problem with optimize 03 Mar 2015 14:23 #1265

By the way, I have tested with HTML minification off and it still fails.

Jordan
The administrator has disabled public write access.

Re: Problem with optimize 03 Mar 2015 16:31 #1266

I have updated to v 5.1 and unfortunately the issue still persists - losing CSS and JS combination after a few page reloads when Jotcache enabled.
The administrator has disabled public write access.

Re: Problem with optimize 03 Mar 2015 21:54 #1267

For further information,

If I use Protostar template, this does not seem to happen. It seems to be limited in my testing to RocketTheme Ximenia Responsive

Jordan
The administrator has disabled public write access.

Re: Problem with optimize 04 Mar 2015 15:23 #1272

Further testing...

It turns out, that this is not template specific. It only seems to effect the home page.

However, if I access with homepage with:

domain.com/index.php

rather than

domain.com/

Then this solves the problem. So while not ideal, I added this to my htaccess and the problem is gone:

RewriteCond %{HTTP_HOST} ^MyDomain.com$
RewriteRule ^$ MyDomain.com/index.php [L,R=301]

Jordan
The administrator has disabled public write access.

Re: Problem with optimize 05 Mar 2015 10:13 #1275

Hi,

Same problem here.
When JCH Optimize is enable everything run fine at start then after some reload CSS combination file is not found and page is loaded without CSS.

I also have the same problem with some images cached by Yootheme widgetkit.

I will open another subject about setting up cache time in JOT plugin and joomla configuration ...

Joomla version : 3.3
JotCache version : 5.08
site template: Yootheme master 2
system plugins : JCH Optimize Pro 4.2.0
The administrator has disabled public write access.

Re: Problem with optimize 06 Mar 2015 18:36 #1284

I have the exact same problem, but the workaround is not working.

JCH works fine with system cache, but not JOT cache, which seem to cache all the css and js instead of the optimized version.

Joomla version : 3.4
JotCache version : 5.1
site template: rockettheme corvus
system plugins : jch 4.2.1
The administrator has disabled public write access.

Re: Problem with optimize 07 Mar 2015 07:33 #1286

In my case optimizing fails on other pages also, not just the home page.
The problem comes and goes on different pages.

I have the same problem with system cache, not just Jotcache.
I reported the issue at JCH Optimize. They are working on it.
So far it is very hard to reproduce this problem, which makes it difficult to diagnose.

The JCH plug-in works, but sometimes CSS and JS files are not combined.
The administrator has disabled public write access.

Re: Problem with optimize 07 Mar 2015 13:12 #1287

Strange as I haven't seen the problem yet with joomla cache. Weird problem.
The administrator has disabled public write access.
Time to create page: 0.329 seconds
We have 47 guests and no members online
Copyright © 2015 JotComponents
We have 47 guests and no members online
Copyright © 2017 JotComponents