TOPIC: JotCache still caching excluded pages

JotCache still caching excluded pages 30 Mar 2016 18:16 #1678

I'm trying to get a form made using BreezingForms working on a website. I created the form and used the BreezingForms plugin to add it to a page. The problem is that when the cached version of the page is used, the from does not submit correctly. If I load the page, then clear the cache, the form works. I have tried excluding the page by going to Exclude URL and checking the boxes by BreezingForms and com_content. I also added "article&id=
Article cannot be shown
The administrator has disabled public write access.

JotCache still caching excluded pages 31 Mar 2016 07:11 #1679

URL exclusion rule "article&id=" is not complete (number after id= is missing). For exclusion of one specific page URL use as better parameter the page Itemid. The JotCache exclusions are explained in slide on SlideShare
The administrator has disabled public write access.

JotCache still caching excluded pages 31 Mar 2016 16:13 #1680

I do have the number in there. I'm trying to exclude article 3878 so I put id=3878 in the line for the exclusions. We already have an article excluded, so the string looks like this:
id=3470,id=3470&catid=2,article&id=3878

I've also tried the following without success:
id=3470,id=3470&catid=2,id=3878

I don't know if it is the plugin that is pulling in the form causing the issue, but when I exclude the BreezingForms component and go directly to the form in joomla, I'm able to use the form with no issues. When I go to the article that's using the BreezingForms plugin to pull in the form, it doesn't work properly unless I load the page then clear the cache before submitting, which isn't practical for a form meant to be used for submitting IT tickets.
The administrator has disabled public write access.

JotCache still caching excluded pages 27 Nov 2016 23:54 #1830

Was this ever resolved?

I've just installed JotCache and am having the same problem. In my case I want to exclude a page that runs a PHP script to display a What's On event. In theory it should be possible to exclude any page that has a ? in the URL. And in fact the page doesn't show in the JotCache list of cached pages. However, in practice the page gets stuck on the first event that is clicked on.

I suspect that the page is being cached not by JotCache but by the Joomla caching system with settings in Global Settings. I've reduced the global setting for caching to 1 minute (the minimum) and it looks as if this shortens the time that the events page is cached, but that's not an acceptable situation.

Before installing JotCache I was using CacheControl. That solves this particular problem. I could exclude the event details page simply by specifying the URL and there would be absolutely no caching of it. However, CacheControl is in other ways not as powerful a tool as JotCache and doesn't provide the same performance boost.
The administrator has disabled public write access.

JotCache still caching excluded pages 28 Nov 2016 17:13 #1831

Your assumption that in JotCache is exclusion performed on page URL with ?xxx=yyyy&..... is not correct. JotCache 5.1+ exclusion is based on Joomla internal form of URL query, please look on http://kbase.jotcomponents.net/jotcache/help/v50j3x/new51#popup_window_with_page_internal_url. Use these presentation of URL query for exclusion.
Here are very rare cases when exclusion is problematic in JotCache, then use CacheControl along with JotCache enabled.
The administrator has disabled public write access.

JotCache still caching excluded pages 30 Nov 2016 00:44 #1832

Спасибо за ответ

I turned off caching in global settings and the event details page now shows correctly. I'll now follow your advice and reenable CacheControl at the same time as enabling JotCache. I'm now using the correct internal Joomla URLs and those pages do seem not to be cached, so that is good.
The administrator has disabled public write access.

JotCache still caching excluded pages 14 Feb 2017 11:37 #1878

Good Day ! Tell me how to exclude from caching the page. There is a problem on the main page after you enable the caching no longer add items to the cart. It seems that fancybox is disabled, and it just adds a product to the cart. On all other pages works. Joomla 2.5.27 Stable. VM 2.6.8 b. Jotcache 4.2.3

Joomla version : 2.5
JotCache version : 4.2.3
site template: Storeslab_2
system plugins :
The administrator has disabled public write access.
Time to create page: 0.371 seconds
We have 113 guests and no members online
Copyright © 2015 JotComponents
We have 113 guests and no members online
Copyright © 2017 JotComponents