TOPIC: Memcache issue on admin side

Memcache issue on admin side 22 Mar 2015 12:27 #1317

I started using Jotcache with the memcache settings recently, but I had some issues getting it installed correctly. When I chose the option for memcache instead of File, initially the options did not open up. I first had to save the plugin. Then the options did open up, but with default options (serverport). However, these options were already active, and I could not save my desired serverport, because I got a message that memcache was not working. After saving again, my entire backend stopped working with this message (JotCache plugin was disabled).

I managed to solve this by setting the correct serverport through PhpMyAdmin, but maybe this si something to correct in future releases.

For me, no issue, and my site is nice and fast ;)

Joomla version : 3.4
JotCache version : latest
site template:
system plugins :
The administrator has disabled public write access.

Re: Memcache issue on admin side 23 Mar 2015 12:42 #1326

I re-checked this on a test copy of my site on another server, and I did not have the issue there, so it may have been due to my specific server set-up. Can be closed.
The administrator has disabled public write access.

Re: Memcache issue on admin side 23 Jun 2015 20:21 #1391

Where in the DB can I manually change the memcache port?

I tried in xxx_extensions / Jotcache (plugin/system):
{"type":"memcache","persistent":"1","mcompress":"1","host":"localhost","port":"20001"}}

But I am still getting a 404 in the backend.

https://www.dropbox.com/s/sy4o0n67610rytm/Screenshot%202015-06-23%2011.20.39.png?dl=0

Joomla version : 3.4
JotCache version : 5.1
site template: Base3 joomlabamboo
system plugins :
The administrator has disabled public write access.

Re: Memcache issue on admin side 23 Jun 2015 20:35 #1392

Find in DB table #__extensions row with jotcache plugin. In column 'params' is stored json string of JotCache plugin definitions. E.g. :
{"browsercache":"0","cachetime":"20","editdelete":"1","cachemark":"1","autoclean":"0","cleanmode":"1","cleanlog":"0","cachecookies":"","domain":"0","domainfilter":"","urlselection":"0","cacheexclude":"","cacheclient":{"chrome":"1","firefox":"1","msie6":"1","msie7":"1","msie8":"1","msie9":"1","msie10":"1","msie11":"1","safari":"1","desktop":"1","iPad":"1","iPhone":"1","tablet":"1","phone":"1"},"botexclude":"1","storage":{"type":"file","persistent":"0","mcompress":"1","host":"127.0.0.1","port":"20000"}}

Look for the part with
"storage":{"type":"memcache"

Here you can change storage parameters also to file storage type as
"storage":{"type":"file"
The administrator has disabled public write access.

Re: Memcache issue on admin side 23 Jun 2015 20:39 #1393

Bingo! Thanks.

Siteground blundered and disabled memcache on my VPS. So I had 2 sites go down! :-(

All fixed now.
The administrator has disabled public write access.
Time to create page: 0.873 seconds
We have 82 guests and no members online
Copyright © 2015 JotComponents
We have 82 guests and no members online
Copyright © 2017 JotComponents