TOPIC: Issue with cyrillic titles

Issue with cyrillic titles 06 Mar 2015 11:51 #1278

Hi!
I have issue with cyrillic titles.

Jotcache displays cyrillic titles as ???????????



Joomla version : 3.4
JotCache version : Latest
The administrator has disabled public write access.

Re: Issue with cyrillic titles 23 Mar 2015 08:07 #1320

Your server stores cached pages in file system with other encoding as UTF-8. Here are several solutions possible, one of them is adding of following line into .htaccess file :

AddDefaultCharset utf-8
The administrator has disabled public write access.

Re: Issue with cyrillic titles 23 Mar 2015 11:27 #1325

I added AddDefaultCharset utf-8 to .htaccess but it don't fixed issue.
Titles still displays as ????
The administrator has disabled public write access.

Re: Issue with cyrillic titles 12 Nov 2015 18:28 #1525

I have installed component on anoyher joomla site - and title displays fine.
And htacces in this file does not have AddDefaultCharset utf-8 in .htaccess file.
The administrator has disabled public write access.

Re: Issue with cyrillic titles 17 Nov 2015 13:27 #1529

Check the database encoding then.
The administrator has disabled public write access.

Issue with cyrillic titles 17 Nov 2015 14:01 #1530

I have 2 sites with same settings for database and htaccess.
But site displays title fine - second with ?????????
The administrator has disabled public write access.

Issue with cyrillic titles 17 Jan 2016 13:04 #1588

The problem with ???? characters in JotCache Management View page title / page url was located as non-correct charset setting in database.
The table pfx_jotcache should have DEFAULT CHARSET=utf8 (or for some more complicated languages use utf8mb4).

Running following SQL command on database can set proper charset :
ALTER TABLE pfx_jotcache CONVERT TO CHARACTER SET utf8 COLLATE utf8_unicode_ci;
OR for some more complicated languages
ALTER TABLE pfx_jotcache CONVERT TO CHARACTER SET utf8 COLLATE utf8mb4_unicode_ci;
where pfx is table prefix used in your Joomla database.

Some details for charset setting you can also find here http://stackoverflow.com/questions/6115612/how-to-convert-an-entire-mysql-database-characterset-and-collation-to-utf-8
The administrator has disabled public write access.

Issue with cyrillic titles 20 Jan 2016 13:33 #1589

Hi!
I just reinstalled JotCache - and now titles looks fine.
Thanks.
The administrator has disabled public write access.
Time to create page: 0.259 seconds
We have 73 guests and no members online
Copyright © 2015 JotComponents
We have 73 guests and no members online
Copyright © 2017 JotComponents