General informations about JotCache extension

TOPIC: PERIOD at the end of the domain name

PERIOD at the end of the domain name 15 Apr 2017 00:54 #1910

  • Bob Pit
  • Bob Pit 's Avatar
I have a weird problem and this is how to duplicate it.

1) Have jotcache enabled.
2) Clear the cache.
3) Go to the homepage of the website but put a PERIOD at the end (ie go to 'mywebsite.com.' )
4) Now the home page is cached.
5) Go to another menu, then come back to the home page.

From here on several weird things happen to my website:
a) The bootstrap glyphicons on my homepage will appear wrong (different).
b) When I click on another menu and go to another page (ie about.com), the url will appear to be 'mywebsite.com./about.com'.
c) On some pcs the template will almost disappear, I will see only the text of the home page.

+++++++
If I clear the cache or if I just delete the cached home page, and then view the home page on the browser, the problem is gone.
Also if I disable jotcache, the problem is gone.
Have not tried it with Joomla generic cache.

+++++++

This thing with the PERIOD is very common. For example try to go to 'www.ft.com' but add a PERIOD at the end: 'www.ft.com.'
The website will display. Now click on the WORLD menu. It will take you to this page (with the PERIOD: 'www.ft.com./world'

In my case it is the Jotcache that seems to cause extra problem to the website (template and glyphicons do not diplay right ).

Joomla version : 3.6
JotCache version : 5.3 (I think, not sure where to find it)
site template: Purity III from Joomlart
system plugins :
The administrator has disabled public write access.

PERIOD at the end of the domain name 15 Apr 2017 10:39 #1911

Here is no sense to use domain URL with trailing '.'
JotCache is correct working with domain names fullfilling rules of RFC1035 and later.
The administrator has disabled public write access.

PERIOD at the end of the domain name 15 Apr 2017 10:54 #1912

  • Bob Pit
  • Bob Pit 's Avatar
JotComponents wrote:
Here is no sense to use domain URL with trailing '.'

Yes, I know. I never put a training period.

Probably some user does it by mistake and visits the website like this. Maybe a link from some other website is misspelled. Neverthless, I experience this problem.

For some reason the web servers do allow the display of pages with these "illegal" domain names. If jotcache is not enabled, the website displays correctly. When jotcache is enabled, the website starts and becomes corrupted.

Can you help with this please?

Joomla version : 3.6
JotCache version : 5.3 (I think, not sure where to find it)
site template: Purity III from Joomlart
system plugins :
The administrator has disabled public write access.

PERIOD at the end of the domain name 15 Apr 2017 11:29 #1913

  • Bob Pit
  • Bob Pit 's Avatar
Hello

After some research on this, it seems that it is a common problem that does affect cache (in general):
webmasters.stackexchange.com/questions/7...me-with-trailing-dot

Currently looking for an htaccess rule to fix this.

Joomla version : 3.6
JotCache version : 5.3 (I think, not sure where to find it)
site template: Purity III from Joomlart
system plugins : NOVA Madison
The administrator has disabled public write access.

PERIOD at the end of the domain name 15 Apr 2017 11:47 #1914

Yes. The best way is to set .htaccess file to redirect any domain to your preferred protocol/domain e.g. yourwebsite.com
The administrator has disabled public write access.
Time to create page: 0.268 seconds
We have 46 guests and no members online
Copyright © 2015 JotComponents
We have 46 guests and no members online
Copyright © 2018 JotComponents