General informations about JotCache extension

TOPIC: Thousands of weird urls being cached

Thousands of weird urls being cached 23 Mar 2017 19:36 #1896

Hello,

I saw that before but it upsets me.
Thousands of urls are cached but I only have at most 80 pages on my website.

For one article only I can get dozens of urls cached in jotcache.
Most of them are absolutly ridiculous. This one for example :
www.mywebsite.com/index.php/photos/nepal...s-tops/les-tops/inde
It uses category names twice or more.
The category names are not even related to the article it links to.
It uses index.php but my url rewriting in on.
The real article urls is the simplest :
www.mywebsite.com/article-alias

Apparently google does not index these stupid urls but i m still fed up with this non sense.
I'd really like to understand what's wrong with joomla. What did I do wrong.

Thanks for your help.

Joomla version : 3.6
JotCache version : last one
site template: my own
system plugins : admin tools, jchoptimize
The administrator has disabled public write access.

Thousands of weird urls being cached 26 Mar 2017 09:43 #1901

Thousands of urls are cached but I only have at most 80 pages on my website.
It is result of dubious requests coming from many crawlers which spoil internet (some of them are site attacks). You can find such requests in access log of your web server. For supressing of some types of dubious request is necessary in JotCache plugin to set URL Filter parameter to 'Yes'. In your case also can help setting of ExcludeURLs with Query String to 'Yes':

For exclusion of requests with other protocol/subdomain is usefull to set Multisite parameter to 'Yes' and include your standard domain in Domain Filter:
The administrator has disabled public write access.

Thousands of weird urls being cached 01 Apr 2017 20:04 #1905

Thanks for your answer !

Site attacks is a good explanation of what's happening to my website. I wonder why the site attacks crawlers crawl thoose weird urls.

All the settings you advised me ti tick are were already. Actually all of them but the "mutisite setting". As far as I know I don't use subdomains so I wonder if it will have an effect on my issue. If I use one (not sure) it's a with "www" and a without "www"
The administrator has disabled public write access.

Thousands of weird urls being cached 02 Apr 2017 08:03 #1906

JotCache parameter "Multisite" together with "Domain Filter" can further narrow the scope of cached pages also in case of one-domain site. You must decide which form you want to use either "www.mywebsite.com" or "mywebsite.com" and then set it proper in .htaccess file (to redirect all requested URL to only one preferred domain) and "Domain Filter" parameter.
The administrator has disabled public write access.
Time to create page: 0.234 seconds
We have 24 guests and no members online
Copyright © 2015 JotComponents
We have 24 guests and no members online
Copyright © 2018 JotComponents